Issue with Box Services

Incident
July 07, 8:45pm

Issue with Box Services

Status: closed
Start: July 07, 7:00pm
End: July 07, 8:45pm
Duration: 1 hour 45 minutes
Affected Components:
box Box Website Box Notes Desktop Applications Box Platform / API
Update

July 07, 7:00pm

July 07, 7:00pm

On July 7th, 2022 between 6:02 PM PDT and 7:10 PM PDT, some users may have experienced difficulties while working in Box. During this time, users may have experienced higher than normal latency, timeouts and/or errors when trying to access Box via one of our applications or our Public API. The issue occurred due to instability in one of our HBase clusters, resulting in increased request queue latencies and degradation of uploads, downloads, Box Notes, and other related services. We were able to resolve the issue by diverting traffic to a healthy passive cluster. In addition, we are working on process and tooling improvements to prevent similar issues from occurring in the future.  ‌ We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. We will publish the results as soon as we have concluded our investigation. We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.  Sincerely, The Box Team

Update

July 07, 7:00pm

July 07, 7:00pm

We are currently investigating an issue with Box services. We will provide more information as it becomes available.

Update

July 07, 7:00pm

July 07, 7:00pm

We are continuing to investigate this issue.

Update

July 07, 7:35pm

July 07, 7:35pm

Our teams have validated that all affected services are recovered at this time. We are continuing to monitor for any additional impact.

Update

July 07, 8:07pm

July 07, 8:07pm

We are continuing to monitor for any further issues.

Resolved

July 07, 8:45pm

July 07, 8:45pm

No additional impact has been observed during monitoring and all services are confirmed fully functional. We are considering the issue to be fully resolved. If you are encountering any issues, please contact Box Support at https://support.box.com.