Issue with Box Notes

Incident
July 08, 7:30am

Issue with Box Notes

Status: closed
Start: July 08, 7:30am
End: July 08, 7:30am
Duration: 1m
Affected Components:
box Box Website Box Notes Desktop Applications Box Platform / API
Resolved

July 08, 7:30am

July 08, 7:30am

From approximately 9:48 AM to 10:15 AM US Pacific time, we had an issue impacting Box Notes. Some users may have also experienced issues with logins, uploads, and downloads as well. Our systems automatically detected and corrected the underlying issue. There is no current impact and no further updates will be provided here. If you are currently seeing any issues, please let us know at https://support.box.com.

Update

July 08, 7:30am

July 08, 7:30am

On July 8, 2022 between 9:50 AM PDT and 10:11 AM PDT, some users may have experienced difficulties while working in Box. During this time, users may have experienced higher-than-normal latency or page errors when trying to use Box, including logging in, uploading or downloading files, using Box Notes, and the Public API. The issue occurred as the result of a change made to our rate limiting system. We were able to quickly resolve the issue by reverting the change. ‌ We are conducting a full engineering postmortem and our overview is subject to change with further analysis and findings. We will publish the results as soon as we have concluded our investigation. We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.  Sincerely, The Box Team