[Critical] Customers may have experienced issues using Admin Console

Incident
August 22, 5:31am

[Critical] Customers may have experienced issues using Admin Console

Status: closed
Start: August 22, 5:30am
End: August 22, 5:31am
Duration: 1 minute
Affected Components:
Box.com
Update

August 22, 5:30am

August 22, 5:30am

From approximately 05:30 AM to 06:10 AM US Pacific time, we observed an issue impacting Box Admin Console. There is no current impact, and no further updates will be provided here. If you continue to experience any issues, please contact Box Support at https://support.box.com.

Resolved

August 22, 5:31am

August 22, 5:31am

Incident closed.